Arreglar el error de xcrun ruta de desarrollo activa inválida en Mac

Si tienes una computadora Mac, sabes que Apple se enorgullece de ofrecer a los usuarios nuevas funciones y diseños innovadores con cada nueva actualización de software. Apple publica actualizaciones de software con bastante frecuencia y es muy importante asegurarse de que la actualización de software de tu Mac se mantenga actualizada. A través de las actualizaciones de software, no sólo se te ofrecen nuevas prestaciones y diseños innovadores, sino también soluciones a muchos problemas. Al actualizar el software de tu Mac, es posible que estés resolviendo problemas en tu ordenador que ni siquiera sabías que tenías.

El software no es perfecto y los errores aparecen a menudo. Por este motivo, a veces, cuando actualizas el software de tu dispositivo, también puedes descubrir nuevos problemas que antes no existían en tu sistema. Sin embargo, esto no es motivo para no actualizar el software de tu sistema. Apple publica constantemente actualizaciones de software posteriores que corrigen los errores de las actualizaciones anteriores.

Si has actualizado recientemente el software de tu Mac, es posible que hayas notado un error xcrun de un error de ruta de desarrollo activo no válido en tu sistema. Aunque esto puede parecer problemático o alarmante al principio, en realidad puedes arreglar fácilmente este problema en cuestión de momentos. Xcrum es un ejecutable de envoltura que viene con Mac OS 10.9 y en adelante. Este ejecutable de la envoltura se instala en /usr/bin. A través de xcrun, eres capaz de encontrar o ejecutar cualquier herramienta dentro de Xcode desde la línea de comandos. Como probablemente sepas, Xcode es un entorno de desarrollo integrado creado por Apple con el propósito de desarrollar software para Mac OS, iOS, watchOS y tvOS.

Hay algunos métodos que puedes llevar a cabo para arreglar el error xcrun de una ruta de desarrollo activa no válida en tu Mac. Te sorprenderá saber que los métodos de resolución de problemas son muy fáciles de llevar a cabo, y sólo requieren unos pocos momentos de tu tiempo. Puedes resolver fácilmente este problema de error instalando las herramientas de desarrollo de Xcode y seleccionando tu versión de Xcode. Para comenzar y aprender cómo puedes solucionar el error de xcrun de una ruta de desarrollo inválida, sigue las sencillas instrucciones que aparecen a continuación.

Instalar las herramientas de desarrollo de Xcode

Si eres un desarrollador ávido, probablemente estés acostumbrado a experimentar muchos errores y fallos durante el proceso de desarrollo. A pesar de tus años de experiencia, ver un bicho implacable puede ser angustioso, ya que buscas y buscas durante horas y horas una solución simple, sólo para descubrirla justo antes de que estés a punto de rendirte.

Por suerte, cuando se trata del error xcrum de un camino de desarrollo activo inválido, la solución es mucho más fácil de lo que podrías imaginar. Puedes resolver fácilmente el problema instalando las herramientas de desarrollo de Xcode. Para empezar y arreglar el error xcrum de un camino de error activo no válido, sigue las sencillas instrucciones de abajo.

Es probable que el error que estás viendo se parezca a esto,

xcrun: error: ruta de desarrollo activa inválida (/Biblioteca/Desarrollador/Herramientas de línea de comandos): falta xcrun en: /Biblioteca/Desarrollador/CommandLineTools/usr/bin/scrun

Este error, sin duda, parece aterrador e intimidante. Por suerte, puedes resolver este problema con un simple paso. Para empezar, simplemente sigue las sencillas instrucciones que aparecen a continuación.

1. Escriba lo siguiente:

xcode-select -install

Es tan simple como eso. Ya está todo hecho. Como puede ver, el proceso fue muy fácil de llevar a cabo y sólo requirió un momento de su tiempo. Tengan en cuenta que tendrán que aceptar explícitamente el acuerdo de licencia, para que este método funcione.

Puede que acabes con múltiples versiones de Xcode al llevar a cabo este método. Esto no es algo de lo que preocuparse, y puedes resolver fácilmente este problema. Para saber más sobre cómo puedes seleccionar tu versión de Xcode preferida, sigue las directrices de la sección siguiente. El proceso sólo le llevará un momento de su tiempo y es muy sencillo de llevar a cabo.

Seleccione su versión de Xcode

No es raro terminar con múltiples versiones de Xcode. Puedes seleccionar fácilmente la versión preferida de tu elección, con un simple comando. Este proceso no tomará mucho tiempo y está garantizado que funcionará. Muy pronto no tendrás que preocuparte por ese molesto error de Xcode. Para empezar, y seleccionar la versión de Xcode que prefieras, sigue las sencillas instrucciones de abajo.

1. Escriba lo siguiente:

xcode-select -switch /Applications/Xcode.app

Arreglar el error de xcrun ruta de desarrollo activa inválida en Mac 1

Sin embargo, si desea ejecutar las herramientas de línea de comandos sin Xcode, entonces simplemente, introduzca lo siguiente:

xcode-select -switch /Biblioteca/Desarrollo/Herramientas de la línea de comandos

Es tan simple como eso. Ya está todo hecho. Como pueden ver, el proceso fue muy fácil de llevar a cabo, y sólo requirió unos pocos momentos de su tiempo. Ya no tendrás que lidiar con el error de Xcrum.

Como ya se ha dicho, no debe evitar actualizar el software de su sistema debido a esta experiencia. Como se ha indicado anteriormente, Apple publica constantemente actualizaciones de software para corregir los errores de las actualizaciones anteriores.

Leave a Reply